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Assign Wall Preferences 

1. From the File menu, select Preferences. 

2. Click Walls/Construction lines in the left pane of the dialog. 

3. Make sure Draw walls using 90 degree angles is unchecked in the right pane. 
 

 

Draw Walls 

Always draw the walls of your designs in a clockwise manner to ensure that the inside dimensions of the room 
are accurate. 

1. Make sure the Ortho mode is activated at the bottom right of the program to restrict the cursor to move 
in 45-degree increments as you draw walls or lines. 

 

2. Click the Continuous icon in the room layout ribbon. You can also use one of the pre-defined wall 
shape icons. 
 

 

3. Click at the bottom left of the floor plan grid.  

4. Move the mouse upward and click when you see 24'' in the Length field of the Placement Box. You 
can also type 24 in the Length field and press ENTER, however, do not move the mouse at all when you 
type dimensions in this box.  
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5. Move the mouse to the right and click when you see 90'' in the Length field of the Placement Box or 
type 90 and press ENTER. 

6. Move the mouse downward and click when you see 24'' in the Length field of the Placement Box or 
type 24 and press ENTER. 

Press the ESC key or right-click to finish drawing walls. Your design should appear as follows: 
 

 

7. Select Content from the Help tab ribbon. 

 

8. Save the design by pressing the CTRL+S and name the design FLEX. 

Note: For all details on drawing walls, look for the Draw walls topic in the Help Content. 

 

Browse the Catalog 

To place closet items in your designs, you must use the FLEX_C catalog which is accessible via the 
Drag & Drop list. Note:  
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1. Click on the Flex for Closets icon from the Items tab ribbon to display the FLEX_C catalog in the 
Closet dialog.  

 
 
The first thing you see at the root of the catalog is PNLS -> Panel Run.  
 

 
 
Beneath, you see a list of item categories (Panels & Dividers, Shelves,Standard Drawers, etc.). When 
you double-click on a category, you see items related to the category. Placeable items are listed with a 
code, a red greater than sign and a description. E.g..  



 

6 

2. Double-click on Standard Drawers to display all the available drawers within this category. 
 

 

3. As you get to know the item codes in the catalog, you can use the Quick Search area to type the first 
letter(s) of the item code that you want to place in the design. As you type more letters, the list of items 
found narrows to the required item(s) only.  
 
Type S in the Quick Search area to display these item codes. 
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This table shows some of the items that you can quickly find by using the Quick Search area. 

To find... ...type these letters in the Quick Search area 

Backs BACK 

Baskets BSK 

Doors DOOR 

Drawers DRW 

Hampers HAMP 

Hooks HOOK 

Panels PNL 

Racks RACK 
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To find... ...type these letters in the Quick Search area 

Rods ROD 

Shelves SHF 

4. Once you have found the item that you want to place, click on it, then click on View to see it before 
placing it or simply select Place or double-click it to place it on the plan. 

5. Once you place an item on the plan, the Closet dialog reappears. Double-click on <Categories> in the 
Closet dialog to return to the root of the catalog. 

Note: For additional details on the Drag & Drop list, look for the Drag and Drop list topic in the Help Content. 
 

Place a Panel Run 

1. To place a Panel Run in a design, use the wall layout that you created in the previous module. 

2. If you had closed the Closet dialog, click the Flex for Closets icon  .  

3. Click in the Quick search area and type P. 

4. Double-click on   

5. Click in the placement zone of the 90" wall. 
 

 

6. When this dialog appears, click the drop-down arrow beside Number of sections, choose 4 sections and 
click OK.  
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7. Move your mouse to the left and click when the Wall left field shows 0" in the Placement Box. 

8. Move your mouse to the right and click when the Width field shows 90" in the Placement Box. 

9. Move your mouse downward and click when the Depth field shows 14" in the Placement Box. You can 
also type 14 and press ENTER, however, do not move your mouse while typing in values. 

10. When the Closet dialog reappears, close it.  

2020 Design automatically calculates and separates the four sections equally and adds the proper quantity of 
panels, top and bottom shelves accordingly! 

 

Edit the Sections of the Pannel Section (PNLS) 

1. Right click on the PNLS on the floorplan and choose Attributes. 

2. Click the Variables tab. 

3. Click on Section 1, change Section Height 1 to 47 and click Apply.  
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4. When this message appears, click OK.  
 

 

2020 Design automatically sets the nearest valid dimension. 

5. Change Section Type 1 to Wall Mounted.  

When you choose Wall Mounted, 2020 Design automatically removes toe kicks and changes the Bottom 
Clearance (36 9/16")  

6. Click on Section 4, change Section Height 4 to 47.  

7. Change Section Type 4 to Wall Mounted and click OK. 

Add an Elevation Area of a Wall 

1. Double-Click in the placement zone of the 90" wall in the Architecture Floorplan tab. 

 

2. Select the All Floorplan tab. 
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3. The elevation area appears above the floorplan. 
 

 

4. Save the design. 

Resize a Wall 

1. Click on the 90'' wall on the floorplan. 

2. Click and hold the mouse button on the following green handle. 
 

 

3. Move the mouse to the right to stretch the wall', then release the mouse button when the Placement Box 
shows 93''.  
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Resize PNLS 

1. Click in the placement zone of the PNLS on the floorplan. 
 

 

2. Click and hold the mouse button on the following green handle. 
 

 

3. Move the mouse to the right to stretch the PNLS to 93'', then release the mouse button when the 
Placement Box shows 93'' in the Width field.  

2020 Design automatically readjusts sections and parts accordingly. 

Change the Section Depth of a PNLS  

1. Right click on the PNLS on the floorplan and choose Attributes. 

2. Click the Variables tab. 

3. Click on Section 2, change Section Depth 2 to 18.  

4. Click on Section 3, change Section Depth 3 to 18 and click Ok.  
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Add an Adjustable Shelf 

1. Make sure the Area Snap mode is deactivated at the bottom right of the program to avoid snaping to 
predefined area settings and take full advantage of the anchor capability. 

 

2. To add a shelf in section 1, click on the Flex for Closets icon . 

3. Type SHFA in the Quick search area. 

4. Double-click on SHFA > Adjustable Shelf in the dialog. 

5. Click in Section 1 in the elevation area. 
 

 

6. Move the shelf it to the required height within the section and click to set.  

The width of adjustable shelve is automatically adjusted. 

7. Select Close from the Closet window. 

8. Select the newly placed shelf and delete it. 

Stack Adjustable Shelves 

To stack shelves quickly every 8", use the Placement Tool as follows: 

1. Select FLEX_C in the Drag & Drop list. 

2. Type SHFA in the Quick Search area of the Drag & Drop list. 
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3. Click on SHFA > Adjustable Shelf. 

4. Type 8 in the Offset field of the Place tab in the Placement Tool. 

5. Click on SHFF in section 1 (handles must appear at the ends). 
 

 

6. Click the up arrow four (4) times in the Placement Tool.  
 

 
 
Result: 
 

 

2020 Design automatically detects the nearest placement holes available for the shelves. 
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7. Stack shelves at every 8" in section 4 using the same process. 
 

 

8. Save the design (CTRL+S). 

Stack Custom Drawers in Section 2 

1. Click on SHFF at the bottom of section 2 (handles must appear at the ends). 

2. Type 0 in the Offset field of the Place tab in the Placement Tool. 

3. Type DRWC in the Quick Search area of the D&D list. 

4. Click on DRWC9 in the Drag & Drop list. 

5. Click the up arrow twice in the Placement Tool.  

6. Click on DRWC6 in the Drag & Drop list. 

7. Click the up arrow twice in the Placement Tool.  
 

 

8. Save the design (CTRL+S). 
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Stack Custom Drawers in Section 3 

1. Click once on the right arrow in the Placement Tool.  

2. Click once on the down arrow in the Placement Tool.  

3. Select DRWC9 in the Drag & Drop list. 

4. Click twice on the down arrow in the Placement Tool.  
 

 

5. Save the design (CTRL+S). 

Add Fixed Shelves that Snap to Drawers 

1. Type SHFFD in the Quick Search area of the D&D list. 

2. Click on SHFFD in the D&D list. 

3. Select the top drawer in section 2. 
 

 

4. Click the up arrow.  

The width of the shelf is automatically adjusted. 
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5. Repeat steps 3 and 4 for Section 3. 

 

6. Save the design (CTRL+S). 

Duplicate Shelves 

1. Right-click on the third shelf in Section 1 and choose Duplicate. 
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2. Click in Section 2, and click to set. 
 

 

3. Repeat the previous steps to duplicate the same shelf in Section 3 and at the same height. 
 

 

4. Save the design (CTRL+S). 

Double Panels 

1. In the Attributes of the PNLS, change the Section Type of Section 1 to Floor Mounted and click OK. 
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Result: 

 

2. Try to drag and drop a DRWC9 in Section 1 via the elevation area. This should not work because the 
drawer has an overlay front and because Sections 1 and 2 have different depths, therefore the overlay 
front is colliding in the panel of Section 2.  

3. To fix this problem, you must first double the panels. Type PNLR in the Quick Search area of the D&D 
list. 

4. Drag and drop the PNLR in Section 1 near the drawers. 

2020 Design automatically redistributes sections evenly. 

5. Click on SHFF at the bottom of section 1 (handles must appear at the ends). 

6. Type 0 in the Offset field of the Place tab in the Placement Tool. 

7. Type DRWC in the Quick Search area of the D&D list. 

8. Click on DRWC9 in the Drag & Drop list. 

9. Click the up arrow once in the Placement Tool.  

10. Save the design (CTRL+S). 

Place a Standard Drawer 

To place standard drawers, baskets, special racks, etc., you must first change the width of a section to a standard 
value such as 24''. 

1. In the Attributes of the PNLS, change the User Defined Section width of Sections 2 to 24 and click 
OK. 
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2020 Design automatically adjusts the width of parts in sections 1, 3 and 4. 

2. While pressing the CTRL key select the 2 DRWC9 drawers in Section 2. 

3. Press the DELETE key. 

4. Use the Placement tool to place two DRWS9 where the DRWC9 used to be in Section 2. 

Use the CTRL key to facilitate the placement of the drawers. 

5. Save the design (CTRL+S). 

Configure Closet Options 

1. Before configuring the closet options of an item, edit the Attributes of the V BOX, change these 
attributes and click OK. 
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2. To select multiple items with Select Region, click and hold the mouse button where you see the " " 
in the picture below. 
 

 

3. Drag the mouse diagonally towards the bottom left to draw a rectangle around the four (4) SHFA 
shelves in Section 4, then release the mouse button here. 
 

 

4. Press the DELETE key. Only the four shelves should be deleted. Press CTRL+Z and start over if more 
items were deleted. 

5. Drag and drop two (2) SHFF fixed shelves in Section 4 (one in the middle and one at the top). 
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6. Drag and drop two (2) RODU rods beneath the shelves in Section 4. 
 

 

7. Save the design (CTRL+S). 

Configure the Closet Options for a Single Item 

1. To view and specify the options of a single item, e.g. a rod, right-click on one of the rods, select RODO 
(RODU), then select Features and Options.  

2. To choose a rod type, select Rod Type on the bottom left section and select the desired type on the 
right-hand side.  

 

3. To also choose a rod color, select Accessory Color on the bottom left section and select the desired 
color on the right-hand side.  Then click OK. 

Configure the Closet Options for Multiple Items 

1. To assign the same options to all the rods in the closet, in addition to other closet options for other parts, 
press the CTRL+A keys to select all the items in the design, then click the Options icon from the Items 
tab of the ribbon. 
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2. To configure the closet option(s) for: 

o a single item, click on a User Code in the top pane of the dialog 

o multiple items randomly, press the CTRL key and click on the required items, then release the 
CTRL key 

o multiple items in a range, press the SHIFT key, click on the first item, click on the last item to 
configure, then release the SHIFT key. 

3. In the bottom pane of the dialog, click on options that require confirmation symbolized with a red 
question mark  in the Options Code column. 

a. You can also select an option from the right-hand side pane. 

4. Repeat these steps for all options with a red question marks .  

5. Click OK in the Features and Options dialog. 

6. Save the design (CTRL+S). 

Replace Multiple Items 

1. Select the items to replace, i.e., select the second, third and fourth shelf in Section 1 with Select Region. 
 

 

2. Type SHFF in the Quick Search area of the D&D list. 

3. Right-click on SHFF > Fixed Shelf in the D&D list and choose Replace. 

4. If required, extend the right end of the shelf to attach it to the vertical panel. 

Replace a Single Item 

1. Click on the last shelf in Section 1. 

2. Type SHFS in the Quick Search area of the D&D list. 
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3. Right-click on SHFS in the D&D list and choose Replace. 

4. Save the design (CTRL+S). 

Use Idea Center 

Idea Center allows you choose from preconfigured ideas to quickly create new designs. You can view the 
details and open the idea once it is selected. Ideas are categorized and sorted by criteria and you can select 
criteria to find the right idea. By creating designs with the Idea Center, you can save a tremendous amount of 
time. In addition, you can even create your own libraries and fill them with ideas! 

Save an idea to Idea Center 

Using the design you previously created, save it to an Idea Center library as follows: 

1. Select your design by pressing the CTRL+A 

2. From the File menu, select Idea Center.  Select Save to Idea Center 

3. In the Save to Idea Center dialog select My Closet Section in the left-hand pane. 

4. Enter an Idea name. * Use alphanumeric characters only. 

5. Enter an Idea description. 
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Select the view 

1. Click Select... to choose an isometric rendering to identify the idea and facilitate searching for ideas.  

You cannot edit the view once it is saved, i.e., you must recreate the idea to change its image. 

o To zoom in/out, rotate the mouse wheel forward/backward. 

o To scroll, press and hold the mouse wheel or click and hold the left and right mouse buttons 
simultaneously. Move the rendering in any direction, then release the wheel. 

o To rotate the image 90 degrees to the right, click the Rotate button. 

o To rotate the image in any direction, click and hold the left mouse button. Rotate the rendering in 
any direction, then release the mouse button. 

2. Click Select to save the view. This may take a while, please wait. 

3. Click Save. 


